Using tortoise svn 1.7 and Delphi XE2

Just a heads up for anyone using tortoise svn 1.7 and Delphi XE2.

It is extremely rare that I’ve needed to use svn via the command line, but in trying it today I received a spurious error:

"svn: '.' is not a working copy"

Turns out the command line version of svn is V1.6 found in C:Program FilesCollabNet. This is installed with XE courtesy of a setup packaged by Collab.net. A little while ago I upgraded my tortoisesvn to 1.7 which employs a different local cache structure. The cryptic error is a result of this incompatibility.

To resolve this I upgraded svn from www.collab.net (after jumping through the registration hoops just for the free download). I could probably have found it from apache.org or somewhere but didn’t want to mess with my environment path, etc. It might well be available from Embarcadero, but couldn’t find it with a quick check.

If you’re still on tortoisesvn 1.6, be aware of this gotcha when upgrading to 1.7.

Posted in IDE, Tools Tagged with: , , ,
One comment on “Using tortoise svn 1.7 and Delphi XE2
  1. Nicholas Ring says:

    I have used Version Insight Plus (http://www.bitcommander.de/blog/) and followed these instructions (http://www.bitcommander.de/blog/index.php/2011/06/01/verins-svn-dlls/) for SVN 1.7 without any issues.

2015 Symposium

Melbourne - March 26

Canberra - March 27

Registrations have now closed.

The ADUG wishes to acknowledge the assistance of the following companies whose sponsorship helps to make our Symposium possible:

Arena Business Technology TCG-Logo Nexus DB Help and Manual Devart Gnostice Information Technologies

Full details on the Symposium page

Archives